Degraded Quick Search performance

Incident Report for CapIntel Prod

Resolved

The issue with the Quick Search AWS cluster has been identified and fully resolved. Please contact support@capintel.com if you encounter issues.
Posted Jun 23, 2026 - 15:11 EDT

Investigating

The Quick Search functionality in Comparisons is currently down. Our team is currently investigating. Please revert back to the Fund Screener in order to pull in securities.
Posted Jun 23, 2026 - 14:16 EDT
This incident affected: api.capintel.io.